Към съдържанието

  •  

IP. Board 3.4.x - фал старт или пълен провал


  • Влезте в профила си за да пишете
49 отговора на тази тема

#1 Beatfan

Beatfan

    Invisionizer

  • Админи
  • PipPipPip
  • 3444 Мнения:
Уроци

Публикувано 19 декември 2012 - 16:43

Пускам специална тема за коментари, защото тези версии на форума се очертават като най-големия провал и скандал в последната история на IPS.
Винаги съм се чудил на политиката на IPS да откриват нова страница във версиите си с огромни промени по кода, вместо да подобряват вече утвърдения и изпитан код и система. Но фактите са такива - така беше при 3.0, при 3.1, при 3.2, при 3.3 беше голям скандал заради скиновете и сега стигнаха дъното с последната си версия 3.4.x, която май е на път да счупи рекордите им по бъгове. Много обичам тази форумна система, затова е направен и този форум, но наистина не мога да намеря логично обяснение на случващото се. Следя релийзите на най-популярните групи в интернет сферата и в момента най-шокиращото е, че най-популярната и уважавана група не е пуснала нулирана версия нито на 3.4.0, нито на 3.4.1 :blink:
Обикновено това го правят до 3 дена след официалното пускане на версията. И тъй като те държат на реномето си и никога не пускат боклуци - извода се налага от само себе си. Изключително жалко е да продаваш много скъпа форумна система, на която дефакто клиентите не могат да разчитат и е пълна с все повече бъгове от версия на версия. Меко казано - абсурдно.
Редакторът за писане на мнение става по-зле от версия на версия. Старият редактор от версии 2.3.x няма алтернатива в момента по удобство и сигурност - тоест без бъгове. Но не - трябва да е CKE, javascript простотии и.т.н.
Страшно съм разочарован... Имам наблюдения как огромни софтуерни компании, с присъствие над 10 години в сферата буквално се самоубиха с пускане на некачествени и бъгави версии на програмата си и принудиха много потребители да ползват стари стабилни версии. За съжаление май и тук нещата отиват натам. Но тук е по сложно и Downgrade е невъзможен! Иначе аз лично отдавна да съм се върнал на 2.3.6!

#2 D-rA

D-rA

    Луд умора няма

  • Админи
  • PipPipPip
  • 1089 Мнения:
Уроци

Публикувано 19 декември 2012 - 21:52

Аз затова не ъпгрейтвам. Пазя си активен форум на 2.3.6 - никакви ядове с него/ пу пу пу/ и 3.3.4 за целите за които го ползвам - за сега е стабилен.
Иначе и мен ме учудва защо още я няма нулирана 3.4.х - явно си прав за бъгове и простотии които са вкарали.

Оказа се че все пак я има 3.4.0 - тия дни ще си поиграя и с нея.

#3 Tishu

Tishu

    Darkness inside me ..

  • Собственици
  • PipPipPip
  • 2307 Мнения:
  • IPB версия:3.1
  • Форум URL
  • Град:Раднево/Габрово
Уроци

Публикувано 20 декември 2012 - 09:57

За промените, които извършват по кода ги оправдавам донякъде. IPS винаги се стремят да предлагат продукти, които са актуални и в крак с новите тенденции. Евала примерно за последната версия, че решиха да вкарат СЕО настройките към ядрото, а не човек да ходи да търси 746387263 отделни модула за това, но жестоко НЕ разбирам как не могат да напишат 100 реда свестен код. За последната 1 година няма вариант, в който да са пускали нещо ново и да няма 84728342 бъга в него и както каза Invisionbg тенденцията е с всяка нова версия те да стават повече. Другото лошо нещо е обвързването им с други фирми. Започнаха да интегрират маса неща, които не ги засягат и като се яви някои проблем и има: "Ами това не е наше разширение, ще се оправи проблема, но не се знае кога." о.0.

И мен сериозно започна да ме "боли" от това IPB, няма да се откажа от него, но пък доста добре се стараят да ни измъчват до максимална степен. Наскоро един приятел ми сподели, че иска да upgrade до последната версия (сега е на 3.1.4) ... как да му кажа, че има много хубави неща, но има и един тон бъгове с него.

Ще си стоим на стари версии докато наистина нещо качествено не се появи на бял свят и ПОНЕ да е стабилно с ... 5-10 бъга (това се понаса), а не с 50-100.


П.С. По-скоро според мен е фал старт и до 1-2 релайза нещата ще са по-добре (многоооо се надявам).

#4 pgplamen

pgplamen

    Напреднал

  • VIP
  • PipPipPip
  • 313 Мнения:

Публикувано 20 декември 2012 - 12:13

Аз си мислех да мина на по- високата версия но след написаните редове се отказвам тотално поне за сега. Ще изчакам както казва Tishu да минат 1-2 релиза и нещата да се оправят.


#5 D-rA

D-rA

    Луд умора няма

  • Админи
  • PipPipPip
  • 1089 Мнения:
Уроци

Публикувано 20 декември 2012 - 15:08

Има нещо гнило в "Дания" - явно. Правя опит за инсталиране на чисто на 3.4.0 - всичко върви ок, до момента на стартиране на инсталационния процес - тогава ме изхвърля в driver error. Водих до сега кореспонденция с подръжката на хоста - всичко провериха и отговора им е:

Данните, които използвате изглежда правилни. За съжаление нямаме представа, защо вашето приложение дава тази грешка.

Прилагам скрийншот - за това което се получава. Ако някой има идея - да пише:
Прикачен файл  error.png   43,29K   125 Брой сваляния

ПП. Скоро правих инсталации на 3.1.х и после и на 3.3.4 - никакви ядове.
А сега изтеглих и php то им за проверка на сървъра - всичко което изискват е ОК.

#6 pgplamen

pgplamen

    Напреднал

  • VIP
  • PipPipPip
  • 313 Мнения:

Публикувано 20 декември 2012 - 15:27

Какви са изискванията на 3.4.0. Предполагам че от там идва проблема. Но пък всичко свети в зелено и до момента е преминало. То не може да се инсталира камо ли да се ползва. :ag:

#7 poznai

poznai

    IP.Board user

  • VIP
  • PipPipPip
  • 415 Мнения:
Уроци

Публикувано 20 декември 2012 - 15:57

Има нещо гнило в "Дания" - явно. Правя опит за инсталиране на чисто на 3.4.0 - всичко върви ок, до момента на стартиране на инсталационния процес - тогава ме изхвърля в driver error. Водих до сега кореспонденция с подръжката на хоста - всичко провериха и отговора им е:

Прилагам скрийншот - за това което се получава. Ако някой има идея - да пише:
Прикачен файл  error.png   43,29K   125 Брой сваляния

ПП. Скоро правих инсталации на 3.1.х и после и на 3.3.4 - никакви ядове.
А сега изтеглих и php то им за проверка на сървъра - всичко което изискват е ОК.

виж в кеша каква грешка ти дава

#8 D-rA

D-rA

    Луд умора няма

  • Админи
  • PipPipPip
  • 1089 Мнения:
Уроци

Публикувано 20 декември 2012 - 17:22

Видях я грешката - това не знаех че в кеша се записва - благодаря.
Error 1146: Липсва таблица ."...база.groups"
Писах на хоста и чакам да ми дадат акъл.

ПП. Ето я грешката
Прикачен файл  sql_error2.png   10,41K   113 Брой сваляния
От хоста казаха че вероятно инсталаторът се опитва да въведе данни в таблица която я няма - да де, но в тази нова база няма нито една таблица все още...

#9 Tishu

Tishu

    Darkness inside me ..

  • Собственици
  • PipPipPip
  • 2307 Мнения:
  • IPB версия:3.1
  • Форум URL
  • Град:Раднево/Габрово
Уроци

Публикувано 20 декември 2012 - 17:25

Да не да си препуснал да зададеш права на SQL username да пише в базата данни.

#10 D-rA

D-rA

    Луд умора няма

  • Админи
  • PipPipPip
  • 1089 Мнения:
Уроци

Публикувано 20 декември 2012 - 17:31

Всички права има.

#11 Tishu

Tishu

    Darkness inside me ..

  • Собственици
  • PipPipPip
  • 2307 Мнения:
  • IPB версия:3.1
  • Форум URL
  • Град:Раднево/Габрово
Уроци

Публикувано 20 декември 2012 - 17:38

Добрем....

1. От къде си свали това 3.4.0
2. Table prefix слагаш ли (не е много препоръчително)

Аз тествах 3.4.0 и нямах никакви проблеми с инсталацията или каквото и да е било след нея (освен 8432782 бъгове де). Интересно..

#12 D-rA

D-rA

    Луд умора няма

  • Админи
  • PipPipPip
  • 1089 Мнения:
Уроци

Публикувано 20 декември 2012 - 17:48

От руснаците /и предишните версии от тях са без проблем/
Опитвах със и без префикс, все тая.

#13 Tishu

Tishu

    Darkness inside me ..

  • Собственици
  • PipPipPip
  • 2307 Мнения:
  • IPB версия:3.1
  • Форум URL
  • Град:Раднево/Габрово
Уроци

Публикувано 20 декември 2012 - 17:56

Ами препоръчвам ти да смениш доставчика (руснаците :Д)

#14 D-rA

D-rA

    Луд умора няма

  • Админи
  • PipPipPip
  • 1089 Мнения:
Уроци

Публикувано 20 декември 2012 - 18:39

Явно си е била бъгава - тази която вчера свалих. Сега свалих друга - от други руснаци и вече се инсталира

#15 pgplamen

pgplamen

    Напреднал

  • VIP
  • PipPipPip
  • 313 Мнения:

Публикувано 21 декември 2012 - 02:39

Ще очакваме коментари.

#16 D-rA

D-rA

    Луд умора няма

  • Админи
  • PipPipPip
  • 1089 Мнения:
Уроци

Публикувано 21 декември 2012 - 11:27

Поне за няколкото часа снощи дето се заиграх се държи стабилно - но все още е чиста версия, без приложения - та се въздържам от оценки.

#17 Beatfan

Beatfan

    Invisionizer

  • Админи
  • PipPipPip
  • 3444 Мнения:
Уроци

Публикувано 21 декември 2012 - 13:25

А аз не спирам да се чудя защо тестваш 3.4.0 версия, при положение, че има излязла 3.4.1 със закърпени стотици бъгове. Губиш си времето, но ти си знаеш...

#18 D-rA

D-rA

    Луд умора няма

  • Админи
  • PipPipPip
  • 1089 Мнения:
Уроци

Публикувано 21 декември 2012 - 13:35

От любопитство. Иначе и следващите ще кача пак по същата причина. :)

#19 Tishu

Tishu

    Darkness inside me ..

  • Собственици
  • PipPipPip
  • 2307 Мнения:
  • IPB версия:3.1
  • Форум URL
  • Град:Раднево/Габрово
Уроци

Публикувано 21 декември 2012 - 15:36

btw гледам, че на официалния форум са на 3.4.2 вече .... очакваме го скоро :)

#20 pgplamen

pgplamen

    Напреднал

  • VIP
  • PipPipPip
  • 313 Мнения:

Публикувано 21 декември 2012 - 17:21

btw гледам, че на официалния форум са на 3.4.2 вече .... очакваме го скоро :)


Дано е скоро.


0 потребител(и) четат тази тема

0 потребители, 0 гости, 0 анонимни